Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 13, 2025 - 11:00 CEST
Scheduled
Dear Customer,
We are extending the maintenance time for additional 2 hours.
Extension of maintenance is scheduled as follows:
Start time: 13/08/2025, 08:00 UTC End time: 13/08/2025, 10:00 UTC
During this time, Maestro Activation Bidding activity may be lower than usual in the US, EU and APAC region as we will be pausing all running campaigns.
Access to the Maestro UI will remain fully available.
We appreciate your patience and understanding and apologize for the inconvenience caused.
Thank you.
Posted Aug 13, 2025 - 10:52 CEST
This scheduled maintenance affected: Media Buying.