Delivery regulation issue
Incident Report for Equativ
Resolved
Dear customer,

This incident has been resolved. We appreciate your patience and understanding during this time and apologize for any inconvenience caused.

#inc-946
Posted May 14, 2024 - 05:44 CEST
Identified
Dear Customer,

You may experience a delivery regulation issue (insertions delivery pace).
Our team is actively investigating this problem and endeavoring to resolve it.
We will provide you with updates on our progress.

We apologize for the inconvenience.

#inc-946
Posted May 13, 2024 - 16:23 CEST
This incident affected: Delivery US and Delivery EMEA / APAC.