[EMP] #INC-963 & 964 - Reporting and Delivery
Incident Report for Equativ
Resolved
This incident has been resolved.
Posted May 31, 2024 - 12:41 CEST
Identified
Dear customer,

We are facing an incident that may impact todays reporting accuracy as well as ads delivery.
Our teams are doing their best to mitigate the issue as quickly as possible. We will update you on the progress.

We thank you for your patience.
Posted May 30, 2024 - 11:13 CEST
This incident affected: Delivery US, Delivery EMEA / APAC, and Reporting.