EMP and Maestro interface down

Incident Report for Equativ

Resolved

This incident has been resolved. Sorry for the inconvenience.
Posted Mar 31, 2025 - 12:03 CEST

Identified

Dear customer,

We are currently investigating a technical issue affecting the EMP and Maestro interfaces. Our teams are actively working on identifying the root cause and restoring normal service as quickly as possible.

Thank you for your patience

#inc-1244
Posted Mar 31, 2025 - 11:31 CEST
This incident affected: EMP UI and EBC UI.