Delivery regulation issue
Incident Report for Equativ
Resolved
This incident has been resolved.
Posted May 06, 2024 - 16:48 CEST
Investigating
Dear Customer,

We are currently experiencing a delivery regulation issue (insertions delivery pace).
Our team is actively investigating this problem and endeavoring to resolve it.
We will provide you with updates on our progress.

We apologize for the inconvenience.
Posted May 06, 2024 - 15:52 CEST
This incident affected: Delivery US and Delivery EMEA / APAC.