Decrease of bids from Activation Module bidder

Incident Report for Equativ

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 18:26 CEST

Investigating

Dear customer,

You may experience a decrease of bids for campaigns created in the Activation module in Maestro since 01/04 11:30am UTC. As the issue comes from a US data center, inventory coming from the US and other countries in the Americas is the most affected.

Our technical teams are investigating the root cause.

We apologize for the inconvenience.

#1247
Posted Apr 01, 2025 - 16:10 CEST
This incident affected: Media Buying.