EBC is down
Incident Report for Equativ
Resolved
Dear customer,
The incident has been resolved at 18:00 UTC. Thank you for your understanding.
Posted Mar 21, 2024 - 04:27 CET
Update
Dear customer,
EBC is now available but you may be experiencing longer loading time than usual.
We are working to fully resolve the issue and we thank you for your understanding
Posted Mar 20, 2024 - 16:03 CET
Investigating
Dear Customer,
Equativ Buyer Connect is currently unavailable.
We are working actively to resolve the issue.
We appreciate your patience and understanding and are sorry for the inconvenience.
Posted Mar 20, 2024 - 15:43 CET